re = /(?<=")[^"]+?(?="(?:\s*?,|\s*?$))|(?<=(?:^|,)\s*?)(?:[^,"\s][^,"]*[^,"\s])|(?:[^,"\s])(?![^"]*?"(?:\s*?,|\s*?$))(?=\s*?(?:,|$))/m
str = 'it, finds, values, in, comma, separated, lists
(it also matches new lines and any whitespace, hence the end-of-line highlight)
it, "handles double quotes"
it, "handles, double, quotes, with, commas, in, them"
it, ignores, trailing whitespaces
" unless it\'s in quotes "
,,,,,and,,,,,handles-??-weird.stuff,,,,,,?????
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end