const regex = /(?<=")[^"]+?(?="(?:\s*?,|\s*?$))|(?<=(?:^|,)\s*?)(?:[^,"\s][^,"]*[^,"\s])|(?:[^,"\s])(?![^"]*?"(?:\s*?,|\s*?$))(?=\s*?(?:,|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=")[^"]+?(?="(?:\\s*?,|\\s*?$))|(?<=(?:^|,)\\s*?)(?:[^,"\\s][^,"]*[^,"\\s])|(?:[^,"\\s])(?![^"]*?"(?:\\s*?,|\\s*?$))(?=\\s*?(?:,|$))', 'gm')
const str = `it, finds, values, in, comma, separated, lists
(it also matches new lines and any whitespace, hence the end-of-line highlight)
it, "handles double quotes"
it, "handles, double, quotes, with, commas, in, them"
it, ignores, trailing whitespaces
" unless it's in quotes "
,,,,,and,,,,,handles-??-weird.stuff,,,,,,?????
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}