use strict;
my $str = 'it, finds, values, in, comma, separated, lists
(it also matches new lines and any whitespace, hence the end-of-line highlight)
it, "handles double quotes"
it, "handles, double, quotes, with, commas, in, them"
it, ignores, trailing whitespaces
" unless it\'s in quotes "
,,,,,and,,,,,handles-??-weird.stuff,,,,,,?????
';
my $regex = qr/(?<=")[^"]+?(?="(?:\s*?,|\s*?$))|(?<=(?:^|,)\s*?)(?:[^,"\s][^,"]*[^,"\s])|(?:[^,"\s])(?![^"]*?"(?:\s*?,|\s*?$))(?=\s*?(?:,|$))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}