import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n([A-Z])";
final String string = "I like to start this exercise with a slow metronome and gradually raise the tempo. I use singles, doubles, and paradiddles but you can also use pretty much any other rudiment.\n"
+ "The idea is to play the part that one hand would normally play but with unison strokes.";
final String subst = "[::jump::]$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}