const regex = /\n([A-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n([A-Z])', 'gm')
const str = `I like to start this exercise with a slow metronome and gradually raise the tempo. I use singles, doubles, and paradiddles but you can also use pretty much any other rudiment.
The idea is to play the part that one hand would normally play but with unison strokes.`;
const subst = `[::jump::]$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);