import Foundation
let pattern = #"\n([A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
I like to start this exercise with a slow metronome and gradually raise the tempo. I use singles, doubles, and paradiddles but you can also use pretty much any other rudiment.
The idea is to play the part that one hand would normally play but with unison strokes.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[::jump::]$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)