// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\n([A-Z])").unwrap();
let string = "I like to start this exercise with a slow metronome and gradually raise the tempo. I use singles, doubles, and paradiddles but you can also use pretty much any other rudiment.
The idea is to play the part that one hand would normally play but with unison strokes.";
let substitution = "[::jump::]$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}