re = /\n([A-Z])/m
str = 'I like to start this exercise with a slow metronome and gradually raise the tempo. I use singles, doubles, and paradiddles but you can also use pretty much any other rudiment.
The idea is to play the part that one hand would normally play but with unison strokes.'
subst = '[::jump::]$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result