using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:(?<three>\d+),)?(?<two>\d+),)?(?<one>\d+)$";
string input = @"1,4,34
5,15
22
1,2,3
11,12
11,12,13
1,2
1
,1,2,3
,1,2
,1
,
1234
1,234
1234,123
1,2
111,222
111,2,4444
11,22
12345,12345,12345
12345,12345,12345,12345
,,
1,
1,2,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}