package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:(?<three>\d+),)?(?<two>\d+),)?(?<one>\d+)$`)
var str = `1,4,34
5,15
22
1,2,3
11,12
11,12,13
1,2
1
,1,2,3
,1,2
,1
,
1234
1,234
1234,123
1,2
111,222
111,2,4444
11,22
12345,12345,12345
12345,12345,12345,12345
,,
1,
1,2,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}