// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:(?<three>\d+),)?(?<two>\d+),)?(?<one>\d+)$").unwrap();
let string = "1,4,34
5,15
22
1,2,3
11,12
11,12,13
1,2
1
,1,2,3
,1,2
,1
,
1234
1,234
1234,123
1,2
111,222
111,2,4444
11,22
12345,12345,12345
12345,12345,12345,12345
,,
1,
1,2,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}