import Foundation
let pattern = #"^(?:(?:(?<three>\d+),)?(?<two>\d+),)?(?<one>\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1,4,34
5,15
22
1,2,3
11,12
11,12,13
1,2
1
,1,2,3
,1,2
,1
,
1234
1,234
1234,123
1,2
111,222
111,2,4444
11,22
12345,12345,12345
12345,12345,12345,12345
,,
1,
1,2,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)