import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(?<three>\\d+),)?(?<two>\\d+),)?(?<one>\\d+)$";
final String string = "1,4,34\n"
+ "5,15\n"
+ "22\n"
+ "1,2,3\n"
+ "11,12\n"
+ "11,12,13\n"
+ "1,2\n"
+ "1\n"
+ ",1,2,3\n"
+ ",1,2\n"
+ ",1\n"
+ ",\n"
+ "1234\n"
+ "1,234\n"
+ "1234,123\n"
+ "1,2\n"
+ "111,222\n"
+ "111,2,4444\n"
+ "11,22\n"
+ "12345,12345,12345\n"
+ "12345,12345,12345,12345\n"
+ ",,\n"
+ "1,\n"
+ "1,2,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}