import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?s).*examples?:$";
final String string = " /**\n"
+ " * Alias for {@link #toWithFixedName(String, String...)}.\n"
+ " *\n"
+ " * @param name The optional name of the TO receiver(s) of the email. If multiples addresses are provided, all addresses will be in\n"
+ " * this same name. Examples:\n"
+ " * @param oneOrMoreAddresses Single RFC2822 address or delimited list of RFC2822 addresses of TO receiver(s). Any names included are ignored if a\n"
+ " * name was provided. Examples:\n"
+ " * <ul>\n"
+ " * <li>lolly.pop@pretzelfun.com</li>\n"
+ " * <li>Lolly Pop<lolly.pop@pretzelfun.com></li>\n"
+ " * <li>a1@b1.c1,a2@b2.c2,a3@b3.c3</li>\n"
+ " * <li>a1@b1.c1;a2@b2.c2;a3@b3.c3</li>\n"
+ " * </ul>\n"
+ " */";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}