import Foundation
let pattern = #"(?i)(?s).*examples?:$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
/**
* Alias for {@link #toWithFixedName(String, String...)}.
*
* @param name The optional name of the TO receiver(s) of the email. If multiples addresses are provided, all addresses will be in
* this same name. Examples:
* @param oneOrMoreAddresses Single RFC2822 address or delimited list of RFC2822 addresses of TO receiver(s). Any names included are ignored if a
* name was provided. Examples:
* <ul>
* <li>lolly.pop@pretzelfun.com</li>
* <li>Lolly Pop<lolly.pop@pretzelfun.com></li>
* <li>a1@b1.c1,a2@b2.c2,a3@b3.c3</li>
* <li>a1@b1.c1;a2@b2.c2;a3@b3.c3</li>
* </ul>
*/
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)