// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)(?s).*examples?:$").unwrap();
let string = " /**
* Alias for {@link #toWithFixedName(String, String...)}.
*
* @param name The optional name of the TO receiver(s) of the email. If multiples addresses are provided, all addresses will be in
* this same name. Examples:
* @param oneOrMoreAddresses Single RFC2822 address or delimited list of RFC2822 addresses of TO receiver(s). Any names included are ignored if a
* name was provided. Examples:
* <ul>
* <li>lolly.pop@pretzelfun.com</li>
* <li>Lolly Pop<lolly.pop@pretzelfun.com></li>
* <li>a1@b1.c1,a2@b2.c2,a3@b3.c3</li>
* <li>a1@b1.c1;a2@b2.c2;a3@b3.c3</li>
* </ul>
*/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}