const regex = /(?i)(?s).*examples?:$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?s).*examples?:$', 'gm')
const str = ` /**
* Alias for {@link #toWithFixedName(String, String...)}.
*
* @param name The optional name of the TO receiver(s) of the email. If multiples addresses are provided, all addresses will be in
* this same name. Examples:
* @param oneOrMoreAddresses Single RFC2822 address or delimited list of RFC2822 addresses of TO receiver(s). Any names included are ignored if a
* name was provided. Examples:
* <ul>
* <li>lolly.pop@pretzelfun.com</li>
* <li>Lolly Pop<lolly.pop@pretzelfun.com></li>
* <li>a1@b1.c1,a2@b2.c2,a3@b3.c3</li>
* <li>a1@b1.c1;a2@b2.c2;a3@b3.c3</li>
* </ul>
*/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}