#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)"(.*?)" = ".*?""
Local $sString = ""test" = "data";" & @CRLF & _
"" & @CRLF & _
""text" = "data";" & @CRLF & _
"" & @CRLF & _
""this" = "data";"
Local $sSubst = ""$1" = "$1""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)