using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(.*?)"" = "".*?""";
string substitution = @"""$1"" = ""$1""";
string input = @"""test"" = ""data"";
""text"" = ""data"";
""this"" = ""data"";";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}