re = /"(.*?)" = ".*?"/m
str = '"test" = "data";
"text" = "data";
"this" = "data";'
subst = '"$1" = "$1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result