use strict;
my $str = '"test" = "data";
"text" = "data";
"this" = "data";';
my $regex = qr/"(.*?)" = ".*?"/mp;
my $subst = '"$1" = "$1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";