package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"(.*?)" = ".*?"`)
var str = `"test" = "data";
"text" = "data";
"this" = "data";`
var substitution = ""$1" = "$1""
fmt.Println(re.ReplaceAllString(str, substitution))
}