$re = '/"(.*?)" = ".*?"/m';
$str = '"test" = "data";
"text" = "data";
"this" = "data";';
$subst = "\"$1\" = \"$1\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;