import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(.*\\n)*(.+?)(5)\\[(.*)\\](.\\n)*(.*\\n*)*";
final String string = "SHIELD1[1SHIELD,2SHIELDCAP,3SHIELDPERCENT,]\n"
+ "ENERGY2[1POWER,2POWERCAP,3POWERPERCENT,]\n"
+ "STRUCTURE3[1STRUCTUREHP,2STRUCTUREHPCAP,3STRUCTUREHPPERCENT,]\n"
+ "ARMOR4[1ARMORHP,2ARMORHPCAP,3ARMORHPPERCENT,]\n"
+ "OTHER5[1MASS,2BLOCKCOUNT,3SECTOR,4SYSTEM,]\n\n\n"
+ "SELECT THE MENU YOU WANT\n\n"
+ "[REPLACEFIRST](.*\\n)*(.+?)(3)\\[(.*)\\](.\\n)*(.*\\n*)*[WITH]$4";
final String subst = "$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}