$re = '/(?m)(.*\n)*(.+?)(5)\[(.*)\](.\n)*(.*\n*)*/m';
$str = 'SHIELD1[1SHIELD,2SHIELDCAP,3SHIELDPERCENT,]
ENERGY2[1POWER,2POWERCAP,3POWERPERCENT,]
STRUCTURE3[1STRUCTUREHP,2STRUCTUREHPCAP,3STRUCTUREHPPERCENT,]
ARMOR4[1ARMORHP,2ARMORHPCAP,3ARMORHPPERCENT,]
OTHER5[1MASS,2BLOCKCOUNT,3SECTOR,4SYSTEM,]
SELECT THE MENU YOU WANT
[REPLACEFIRST](.*\\n)*(.+?)(3)\\[(.*)\\](.\\n)*(.*\\n*)*[WITH]$4';
$subst = "$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;