import Foundation
let pattern = #"(?m)(.*\n)*(.+?)(5)\[(.*)\](.\n)*(.*\n*)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SHIELD1[1SHIELD,2SHIELDCAP,3SHIELDPERCENT,]
ENERGY2[1POWER,2POWERCAP,3POWERPERCENT,]
STRUCTURE3[1STRUCTUREHP,2STRUCTUREHPCAP,3STRUCTUREHPPERCENT,]
ARMOR4[1ARMORHP,2ARMORHPCAP,3ARMORHPPERCENT,]
OTHER5[1MASS,2BLOCKCOUNT,3SECTOR,4SYSTEM,]
SELECT THE MENU YOU WANT
[REPLACEFIRST](.*\n)*(.+?)(3)\[(.*)\](.\n)*(.*\n*)*[WITH]$4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)