# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/–\s\K(.*)$/<div>$1<\/div>/gm;t' <<< "You go me on the cookie – Männer T-Shirt"