const regex = /–\s\K(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('–\\s\\K(.*)$', 'gm')
const str = `You go me on the cookie – Männer T-Shirt`;
const subst = `<div>$1</div>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);