$re = '/–\s\K(.*)$/m';
$str = 'You go me on the cookie – Männer T-Shirt';
$subst = "<div>$1</div>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;