import Foundation
let pattern = #"–\s\K(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"You go me on the cookie – Männer T-Shirt"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<div>$1</div>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)