#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)–\s\K(.*)$"
Local $sString = "You go me on the cookie – Männer T-Shirt"
Local $sSubst = "<div>$1</div>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)