using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"–\s\K(.*)$";
string substitution = @"<div>$1</div>";
string input = @"You go me on the cookie – Männer T-Shirt";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}