using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:AGATC)+)(?!.*\1)";
string input = @"AGATCAGATCTTTTTTCTAATGTCTAGGATATATCAGATCAGATCAGATCAGATCAGATC
AGATCAGATCAGATCTTTTAGATCAGATCAGATCAGATCAGATCTTCTAATGTCTAGGATATATCAAGATCAGATC_AGATCAGATCAGATC_AGATCAGATCAGATCAGATC
AGATC_AGATCAGATC_AGATCAGATCAGATC_AGATC_AGATCAGATC
re.search returns the first match in the last example.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}