import re
regex = re.compile(r"((?:AGATC)+)(?!.*\1)", flags=re.MULTILINE)
test_str = ("AGATCAGATCTTTTTTCTAATGTCTAGGATATATCAGATCAGATCAGATCAGATCAGATC\n"
"AGATCAGATCAGATCTTTTAGATCAGATCAGATCAGATCAGATCTTCTAATGTCTAGGATATATCAAGATCAGATC_AGATCAGATCAGATC_AGATCAGATCAGATCAGATC\n"
"AGATC_AGATCAGATC_AGATCAGATCAGATC_AGATC_AGATCAGATC\n\n"
"re.search returns the first match in the last example.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")