using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https):\/\/(www.|)upsie.com\/((?:\w+-)+warranty)\/(?:\w+)(.*)";
string input = @"https://upsie.com/smartphone-warranty/iphone?price_ceiling=999
https://upsie.com/smartwatch-warranty/all?brand=Samsung&category=Smartwatch&price_ceiling=299";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}