const regex = /(https):\/\/(www.|)upsie.com\/((?:\w+-)+warranty)\/(?:\w+)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https):\\\/\\\/(www.|)upsie.com\\\/((?:\\w+-)+warranty)\\\/(?:\\w+)(.*)', 'gm')
const str = `https://upsie.com/smartphone-warranty/iphone?price_ceiling=999
https://upsie.com/smartwatch-warranty/all?brand=Samsung&category=Smartwatch&price_ceiling=299`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}