package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https):\/\/(www.|)upsie.com\/((?:\w+-)+warranty)\/(?:\w+)(.*)`)
var str = `https://upsie.com/smartphone-warranty/iphone?price_ceiling=999
https://upsie.com/smartwatch-warranty/all?brand=Samsung&category=Smartwatch&price_ceiling=299`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}