re = /(https):\/\/(www.|)upsie.com\/((?:\w+-)+warranty)\/(?:\w+)(.*)/m
str = 'https://upsie.com/smartphone-warranty/iphone?price_ceiling=999
https://upsie.com/smartwatch-warranty/all?brand=Samsung&category=Smartwatch&price_ceiling=299'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end