import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Car: (.*)|.*";
final String string = "Car: Replace:Brakes<10\n"
+ "Car: Renew: Engine=100000\n"
+ "Car: Replace: Tires=70000\n"
+ "Truck: Renew: Engine=1000\n"
+ "Truck: Replace: Brakes<504";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}