// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Car: (.*)|.*").unwrap();
let string = "Car: Replace:Brakes<10
Car: Renew: Engine=100000
Car: Replace: Tires=70000
Truck: Renew: Engine=1000
Truck: Replace: Brakes<504";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}