const regex = new RegExp('^Car: (.*)|.*', 'gm')
const str = `Car: Replace:Brakes<10
Car: Renew: Engine=100000
Car: Replace: Tires=70000
Truck: Renew: Engine=1000
Truck: Replace: Brakes<504`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);