using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)Male-Cat(?!\S)";
string input = @"Male-Cat Male-Cat Male-Cat-Female
Male-Cat Male-Cat Male-Cat
Male-Cat Female-Cat Male-Cat-Female Male-Cat'
Male-Cat-Female
Male-Cat";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}