import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)Male-Cat(?!\\S)";
final String string = "Male-Cat Male-Cat Male-Cat-Female\n"
+ "Male-Cat Male-Cat Male-Cat\n\n"
+ "Male-Cat Female-Cat Male-Cat-Female Male-Cat'\n"
+ "Male-Cat-Female\n"
+ "Male-Cat";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}