re = /(?<!\S)Male-Cat(?!\S)/
str = 'Male-Cat Male-Cat Male-Cat-Female
Male-Cat Male-Cat Male-Cat
Male-Cat Female-Cat Male-Cat-Female Male-Cat\'
Male-Cat-Female
Male-Cat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end