import re
regex = re.compile(r"(?<!\S)Male-Cat(?!\S)")
test_str = ("Male-Cat Male-Cat Male-Cat-Female\n"
"Male-Cat Male-Cat Male-Cat\n\n"
"Male-Cat Female-Cat Male-Cat-Female Male-Cat'\n"
"Male-Cat-Female\n"
"Male-Cat")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")