# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^Thanks\s*,\s*([A-Z]?[a-z]*)\s*[^!]?$/Thanks, [NAME]/gm;t' <<< "Thanks, Bob
Thanks, Bob.
Thanks, Bob!"