const regex = /^Thanks\s*,\s*([A-Z]?[a-z]*)\s*[^!]?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Thanks\\s*,\\s*([A-Z]?[a-z]*)\\s*[^!]?$', 'gm')
const str = `Thanks, Bob
Thanks, Bob.
Thanks, Bob!`;
const subst = `Thanks, [NAME]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);