// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Thanks\s*,\s*([A-Z]?[a-z]*)\s*[^!]?$").unwrap();
let string = "Thanks, Bob
Thanks, Bob.
Thanks, Bob!";
let substitution = "Thanks, [NAME]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}