$re = '/^Thanks\s*,\s*([A-Z]?[a-z]*)\s*[^!]?$/m';
$str = 'Thanks, Bob
Thanks, Bob.
Thanks, Bob!';
$subst = "Thanks, [NAME]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;