re = /^Thanks\s*,\s*([A-Z]?[a-z]*)\s*[^!]?$/m
str = 'Thanks, Bob
Thanks, Bob.
Thanks, Bob!'
subst = 'Thanks, [NAME]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result